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XML DR Pydro Users Guide 

1 Introduction 
 
XML DR is a Python-based user-interface, used to generate Project Instructions (PI), Descriptive 
Reports (DR), Data Acquisition and Processing Reports (DAPR), and Horizontal and Vertical 
Control Reports (HVCR).  XML DR saves these reports as an XML file, and also can output 
PDF and RTF documents from these files. 

2 General Information 
 
The following information applies to all documents, created with the XML DR application. 

2.1 Installing Pydro 
 
Pydro (v 11.3 or higher) is required to be installed in order to use the XML DR application.  The 
latest version of Pydro can be found on the HydroSoft website.  Download and install the latest 
version of the Pydro Setup file.  A Pydro license is not required to run the XML DR application.   
Pydro must be installed to the (default) C:\Program Files directory: 
 

C:\Program Files\Pydro 
 

2.1.1 First Time Pydro Install 
 
If this is your first time installing Pydro on your PC, you will need to request a license.  To 
request a license, open up the Pydro main application (Start > Programs >Pydro), and click 
“cancel” when you are prompted for a license.  The Pydro interface will then open.  To request a 
license, go to: 
 
File > Email for License 
 
This process generates a Pydro ticket, and a license will be emailed to you shortly.  The Pydro 
license requires the computer’s MAC address, which should be submitted with the Pydro ticket.  
Alternatively, you can email your MAC address directly to hstp.help@noaa.gov.  The subject 
line of the email should indicate that this is a Pydro License Request, and should include the 
Pydro version number (e.g., v11.2).   
 
To find the computer’s MAC address, use the following workflow: 
 

1. Open a command shell: Start > Run > cmd 
2. In the command shell, enter the following: ipconfig/all 
3. The computer’s MAC address is indicated under “Physical Address”, e.g., 00-24-E8-3E-

BF-FD. 
 

https://inside.nos.noaa.gov/hydrosoft/welcome.html
mailto:hstp.help@noaa.gov
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2.2 Starting the XML DR Application 
 
The XML DR application is started from the Pydro folder in the Windows Start menu.  To open 
the XML DR, navigate to:  
 

Start > Programs > Pydro > XMLDR 
 
This will open a new window displaying the XML DR application. 
 
A sub-menu for each document can be accessed through the XML DR file menu.  To create a 
new document, choose New in the appropriate sub-menu (Figure 1).  For example, to generate a 
new Descriptive Report (DR), navigate to: 
 

File > Descriptive Report > New 
 
This will open a blank, editable form, as seen in Figure 2.  Note that there are several tabs along 
the top of the form, corresponding to different sections, which must be completed.   
 

 
Figure 1. Descriptive Report Sub-menu. 
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Figure 2. Opening a New Document. 

 

2.3 Importing XML Project Instructions (PI) 
 
The versatility of XML allows for the import of data from one document into another.  Currently 
certain metadata from the PIs can be imported into both the DR and the HVCR.   
 
Once a new DR or HVCR has been opened, navigate to the appropriate document and choose 
Import PI.  For example, to import the PI into the DR, choose: 
 

File > Descriptive Report > Import PI 
 
You will be prompted to navigate to the appropriate PI file.  Once you’ve selected the PI .xml, 
you must select the appropriate Sheet ID as seen in Figure 3.  The sheet ID is the sheet priority 
number that was assigned to each sheet in the project area.  Several fields in the Project Metadata 
and Registry Metadata sections should now be populated.  You may manually edit fields as 
necessary.  For example, sheets not originally assigned registry numbers in the PIs will be listed 
as HXXXXX, and should be manually updated. 
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Figure 3.  Importing Project Instructions into the Descriptive Report - be sure to select the appropriate field 

sheet to populate the DR with the correct associated metadata. 
 
Once the .xml PIs have been loaded into the document, begin entering in the necessary 
information to complete the DR.   

2.4 Blue Text 
 
Blue text can be found throughout the XML DR forms.  This text provides helpful advice for 
completing the forms and was often extracted directly from the HSSDM. 

2.5 Completing a Document 

2.5.1 Data Entry 
There are various methods for entering data in the XML form:  entry strings, free-flow text, 
check boxes, radio buttons, and drop down lists.   
 
In general, all radio buttons are required to be addressed.  Additional fields may also be 
spawned, based on which choice is selected. 
 
Most drop-down lists are user-editable.  If one of the choices is not applicable, click the field and 
begin typing.  However, it is important for data stewardship to attempt to use the provided 
choices if possible.  If you find that you regularly use a choice, not provided in the form, notify 
the XML DR team so it can be added in the next version. 
 
Most free-flow text is nillable, meaning that it can be left blank if desired. 

2.5.2 Optional Elements 
Many elements, such as images, attached files, Junctions, Charts, etc., are optional.  These 
elements can be added by clicking the Add … (Add Images, Add Charts, Add Junctions, etc.) 
button.  The Add … button will append an entry to the end of the existing list.  Once an element 
has been added, additional entries can be added to the beginning of the list, by using the Insert 
button.  Individual entries can be deleted by using the Remove button. 
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2.5.3 Spell Check 
The XML DR application uses the Pydro spell checker.  Several commonly used terms and 
acronyms have been added to the spell checker’s dictionary.   Note that the spell checker is not 
employed on string fields.  Therefore, it is still the user’s responsibility to check the final 
document for spelling errors. 

2.5.4 Default Text 
Default text may be added to some fields, based on radio button selection.  This text is 
completely user-editable.  “Negative” radio button selection may also create default text to be 
output in the reports, which may not be visible in the form.  For example, Selecting “No” to 
“Were any Danger to Navigation Reports Submitted?” will generate a statement in the DR that 
reads “No Danger to Navigation Reports were submitted for this survey.” 
Please contact the XML DR team with any suggestions for additions or modifications to the 
default text. 

2.5.5 Attaching Images 
To add images, simply click the Add Images button.  In most cases, images are not required.  
Multiple images can be added to most sections. 
 
All attached images must include a Figure Number (number only – do not include the label 
“Figure”), a caption, and a link to the file.  Future functionality may allow for auto-generation of 
the Figure Number.  
 
A thumbnail of the image will appear next to the link.  See Figure 4. 
 

 
Figure 4.  Attaching Images. 

2.6 Saving an XML Document 
 
There are two options for saving an XML document:  Save and Quick Save.   
 
Quick Save should be used to save an unfinished document, where all of the required fields have 
not been entered.  
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Save should be used to save completed documents where all of the required fields have been 
entered.  If you use this option on an incomplete document, you will receive a message warning 
that the XML cannot save to a validating file (See Figure 5).  This simply means that all required 
fields have not been entered and the XML file cannot be validated against the schema.  You will 
then be prompted to Quick Save your file instead.  
 
 

 
Figure 5. Error message encountered when using the Save option for a non-validating .xml file. 

 
Save and Quick Save are both accessed though the document sub-menus (See Figure 6).  Using 
the DR and an example, navigate to:  
 

File > Descriptive Report > Quick Save 
 

or 
 

File > Descriptive Report > Save 
 

 
Figure 5. Quick Save option for saving a partially completed document. 
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2.7 Validating a File 
 
Prior to saving your file, you may wish to check whether all of your required fields have been 
entered and your XML validates against the schema.  To do this, choose Validate from the 
document sub-menu.  As you go through your form, you may notice that some of the element 
fields will turn red.  The red text indicates fields that are required to be filled out before the file 
can be validated (See Figure 7).  Please note that boolean functions do not highlight in red when 
not properly filled out.  Therefore if you receive an error message indicating that the .xml file 
will not validate, please be sure to check all that all radio buttons have been addressed.  
 

 
Figure 7. Once Validate is utilized various elements will turn red in color indicating that the required field 
has not been filled in properly within the document.  In this document the ‘Year’ and ‘Chief of Party’ are 
required in the document, but have not been properly addressed. 
 
It is important to note that the .xml file can be saved anywhere in your file folder structure and 
can also be emailed or moved from one location to another.  Because the files can be opened 
anywhere be mindful that there are not duplicate copies in circulation, and be sure to note which 
files will be utilized to produce a final deliverable to ensure file management best practices. 

2.8 Printing the XML Document 
 
Once the XML file has been validated and saved, it can be output to PDF format.  To do so, open 
the Print DR utility (Figure 8):   
 

File > Print To PDF/RTF 
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Figure 8. Selecting the Print to PDF/RTF file. 

 
The Print DR dialog box will open, and you will be prompted to select your XML file (Figure 9).  
If you want to view the generated PDF file upon completion, click “View file when done”.  To 
create a PDF, select “Create PDF”.  (Note: RTF format is no longer supported for the XML 
reports).  When prompted, browse to the report’s corresponding XSLT file: 
 

C:\Program Files\Pydro\Lib\site-packages\HSTP\xmlDR\schemas\final 
 
Note that each document has its own associated XSLT file.  Be sure to choose the corresponding 
XSLT file for the report you’re trying to print. In future versions of the XML DR software, the 
XSLT file will be selected automatically. 
 

Descriptive Report: DR_Stylesheet.xslt 
Horizontal and Vertical Control Report: HVCR.xslt 
Data Acquisition and Processing Report: DAPR.xslt 

 
After selecting the XSLT file, the PrintDR utility will generate the PDF file, saving it to the same 
directory as the input XML file.   The PDF generation process will take a few moments, as the 
PrintDR utility runs two separate applications to produce the PDF.  
 

 
Figure  9. Print GUI prompts the user to navigate to the appropriate .xml file to print the document. 

 
If you experience difficulties printing to PDF, please ensure that you have Java Runtime 
Environment (JRE) installed on your machine.  JRE is required to run the Apache FOP, which 
the PrintDR utility requires.  Instructions for verifying the presence of JRE are included in the 
FAQ at the end of this User Guide. 
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If JRE is installed on your machine but the XML file still won’t print, make sure that you have 
the main Pydro folder installed to the following (correct) location: 
 

C:\Program Files\Pydro 
 
 

2.9 Signing and Validating 
 
**TBD -- Functionality Pending** 
 
Completed XML documents can be signed by the appropriate personnel (Figure 10).  Signed 
documents can then be validated for completeness and authenticity.  To sign an XML document, 
navigate to: 
 

File > Descriptive Report > Sign 
 
To verify a signed document, navigate to: 
 

File > Descriptive Report > Verify 
 

 
Figure 10. Signing an XML file. 

 
 

2.10 Archive 
 
**TBD – Functionality Pending** 
 
The next version of the XML DR application will include functionality for archiving (packaging) 
the XML documents with all attached images and files.  Until this functionality is available, you 
should keep all attached files in a subfolder of where your document is stored, to allow for easy 
zipping and transmittal. 
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3 Project Instructions 
 
To be completed. 

4 Descriptive Report 
 
The following sections describe functions and issues that are specific to the DR. 

4.1 Tabs 
 
The first tab of the form includes Project and Survey specific metadata, as well information used 
to generate the Title and Cover sheet.  The next five tabs correspond to Sections A-E of the DR, 
as specified in the HSSD:  Area Surveyed, Data Acquisition and Processing, Vertical and 
Horizontal Control, Results and Recommendations, and Approval Sheet.  The final two tabs 
provide a location to attach Appendices and Separates.   
 
Currently, attached PDF files will not be output with the DR into a single PDF.  You will still 
have to concatenate them in Abode Acrobat.  However, attaching your files here will allow for 
them to be included in the archive.  You should avoid attaching any files that already exist in the 
main project data directory. 

4.2 Importing Pydro Line Statistics  
 
A Pydro license is required to run this application, as you will be importing HIPS/SIPS lines into 
Pydro.  (See Section 8 for guidance on how to obtain a Pydro License.)   
 

Step 1. Import processed survey lines into Pydro. 
Start Pydro and navigate to: 

 
Data > (Re)Insert > HIPS/SIPS Survey Lines (Figure 11) 

 
Browse to and select the appropriate survey lines. (You must use the 
FieldUnit_Hull#_Equipment (ex. TJ_S222_Reson7125) directory naming 
conventions, as describe in section 5.1.2.2.2 of the FPM.) 

 
Classify your lines by both mode and type.  This can be modified for individual 
lines by navigating to: 

 
Data > Stats > Survey Line Info 
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Figure 11. Importing Processed CARIS lines into Pydro. 

 

Step 2. Step 2: Save the PSS 

Step 3. Step 3: Import the PSS into the XML DR 
Open the DR document in the XML DR application.  Navigate to: 
 
File > Descriptive Report > Import LNM Stats From PSS (Figure 12) 
 
You will be prompted to browse for you PSS file. 

 

Step 4. Step 4: Verify that the line stats have been correctly imported into the 
statistics section of the DR.   
Values should exist for Survey Dates, LNM Statistics for each vessel, and Total 
Survey LNM.  Currently a bug requires you to enter “0” for both Mainscheme 
Lidar and Lidar Crosslines.  This should be addressed in the next version.   

 
 

 
Figure 12. Importing LMN statistics into the DR GUI. 
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4.3 Comments Boxes 
 
Both Field Comments and Branch Comments can be added to the XML DR (see Figure 13).  
Multiple comments can be added to most sections.  To add a comment, click on the appropriate 
Add Comment button. 
 
Field Comments are intended for internal use only, as discussion/review between field party 
members during field review.  Field Comments will not be retained in the final printed RTF/PDF 
document and should not be retained in the archive XML file.  Future functionality will allow the 
Field comments to be removed during the archive process.  However, in the meantime, it is 
important to delete any field comments prior to submission to the processing branch. 
 
Branch Comments will be retained in the .xml files as ‘red notes’, which will appear in the final 
RTF/PDF document.  All Branch Comments will be retained with the archived XML file. 
 
 

 
Figure 13. The comments boxes are both expanded in this image.  If no comments are necessary, then click on 
the remove button.  Please note that Field Comments will not be retained in the .xml once a validating file is 
signed and verified.  All branch comments will be retained in the final documentation as ‘red notes’. 

4.4 Approval Sheet – Signing Personnel 
 
Fields for Signing Personnel are included in the Approval Sheet Tab.  The name and title of each 
person approving the document should be entered here.  This information will be used to 
generate a table of signing personnel in the RTF/PDF document.  Signing Personnel will then 
need to digitally sign the final PDF.  Note that this is not the same an electronically signing the 
XML file, which will be included as future functionality. 

5 Data Acquisition and Processing Report 
 
The Data Acquisition and Processing Report (DAPR) is an annual report that shall be produced 
once per survey season, with subsequent DAPRs issued by NOAA field units upon effecting a 
significant change to any items in the report.  Refer to HSSD 8.1.5.1 for further guidance.   
 
The following sections describe functions and issues that are specific to the DAPR.   
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5.1 Tabs 
 
The DAPR is divided into four tabs that include basic report metadata (Metadata), as well as 
sections A-C of the DAPR (Equipment, Quality Control, and Corrections To Echo Soundings).  
The content within each of these sections is described in further detail below. 

5.1.1 Metadata 
 
The Metadata tab of the DAPR form includes specific metadata related to the field unit and 
DAPR version.  Indicate the Year, Field Unit, Chief of Party, and Publish Date.  For the first 
DAPR produced each field season, assign a Version of 1.0.  For all subsequent amended DAPRs 
produced during the field season, the Version number should be incremented accordingly (e.g., 
1.1, 1.2, etc.).  In a future version of the XML DR software, the information retained in the 
Metadata tab will be used to populate the DAPR Cover Sheet.  For now, the user will have to 
generate their own Cover Sheet. 

5.1.2 Equipment 
 

The Equipment tab of the DAPR includes vessel and hydrographic systems metadata as specified 
in the HSSD 8.1.5.1.  This tab includes discrete sections for: survey vessels, echo sounding 
systems, manual sounding systems, positioning and attitude systems, sound speed equipment, 
horizontal and vertical control equipment, computer hardware and software, and bottom 
sampling equipment.  Where applicable, the user shall input serial numbers and equipment 
specifications. 
 
Where applicable, the user shall attach the following reports.  All files shall be attached in PDF 
format. 
 

• Echosounder system accuracy test reports 
• POS MV GAMS calibration reports 
• POS MV controller configuration reports 
• Sound speed sensor calibration reports 

5.1.3 Quality Control 
 
The Quality Control tab includes metadata related to data acquisition and processing; quality 
management; and uncertainty and error management.   

5.1.4 Corrections To Echo Soundings 
 
The Corrections To Echo Soundings tab includes metadata related to all corrections applied to 
echo sounding data, either in real-time or post-processing.  This tab includes discrete sections 
for: vessel offsets and layback, static and dynamic draft correctors, system alignment (i.e., patch 
test) correctors, positioning and attitude correctors, tides and water level correctors, and sound 
speed correctors (surface sound speed and sound speed profiles). 
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Where applicable, the user shall attach the following reports.  All files shall be attached in PDF 
format. 
 

• Vessel offset and layback reports 
• Dynamic draft reports 
• System alignment (patch test) reports 

5.2 Adding Additional Discussion and Field Comments 
 

Each section of the DAPR includes a section where the user can input additional discussion, 
additional images, and/or field comments.  The additional discussion and images will be retained 
in the final PDF deliverable, but the Field Comments will not.   
 
The Field Comments functionality allows field users to comment back and forth to one another.  
These field comments are not retained in the final PDF deliverable, but for now are retained in 
the XML.  In order to delete these field comments, the user must manually delete them from 
each section before finalizing the XML document to send to the Hydrographic Branch.  Note: 
future versions of the XML DR software will include a button that automatically deletes all Field 
Comments before sending the XML deliverable to the Hydrographic Branch. 
 

5.3 Attached Files 
 
Currently, attached PDF files will not be output with the DR, DAPR, or HVCR into a single 
PDF.  You will still have to concatenate them in Adobe Acrobat.  However, attaching your files 
here will allow for them to be included in the archive package produced by the XML DR 
software.  You should avoid attaching any files that already exist in the main project data 
directory. 
 
 

6 Horizontal and Vertical Control Report 
 
The following sections describe functions and issues that are specific to the HVCR.  The HVCR 
is project specific, so all sites and techniques employed for the entire project area must be 
accounted for in the document.  The DR will allow the user to specify which sites and techniques 
were utilized for a particular survey area within the project. 
 
 
The first tab of the form includes Project and Survey specific metadata, as well information used 
to generate the Title and Cover sheet.  As mentioned in Section 2.3, the PIs can be loaded into 
the HVCR at the beginning of the data entry process for the document. 
 
The following tab is the Sites tab.  The purpose of this tab is to enter in all site specific 
information pertaining to both horizontal and vertical stations. The Sites tab is broken into Non-
User Installed and User Installed sites.  Development is currently underway to provide the 
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functionality to have the PIs populate the Non- User Installed site information; however, for now 
this information must be manually entered.  In some cases there may not be any User Installed 
sites that pertain to the survey, if this is the case please indicate that the control was not 
established by indicating the appropriate radio button.  Additionally, any Opus, Field 
Observations Logs, and Quality Control Reports are attached in the User Installed section.   
 
The Techniques tab asks the user to provide information based on the methods utilized for the 
establishment of vertical and horizontal control for the survey area.  At least one method must be 
selected for both vertical and horizontal control; although more than one method can also be 
selected for each type. 
 
The final tab is for the indication of the final approval of the document.  This section must be 
filled out before a validating .xml file can be produced.  
 
Currently, attached PDF files will not be output with the HVCR into a single PDF.  You will still 
have to concatenate them in Abode Acrobat.  However, attaching your files here will allow for 
them to be included in the archive.  You should avoid attaching any files that already exist in the 
main project data directory. 
 
Future functionality will allow the HVCR to be loaded into the DR and populate some of the 
relevant fields (e.g. Vertical and Horizontal Control section found in the DR). 
 

7 Providing Feedback to the XML Metadata Team 
 
You are encouraged to provide feedback as to the usability, functionality, and 
comprehensiveness of this product.  To provide feedback please email the XML team at: 
xml.dr@noaa.gov.  We will take all suggestions under consideration; please do not hesitate to 
send us your requests and feedback so that we can continue to improve this product for you and 
others. 
 
 

8 Frequently Asked Questions (FAQ) 
 
What does the field receive from Project Managers at HQ? 
 
The field should receive both the XML and PDF versions of the project instructions, along with 
any attached images or appendices. 
 
What is submitted to the Branch? 
 
In addition to the Hydro Survey package traditionally delivered to the Branch, you will provide 
them with all finalized XML files for the DR, HVCR, and DAPR as necessary.  You will also 
continue to provide them with signed PDF documents of those corresponding files. 
 

mailto:xml.dr@noaa.gov
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What is the difference between Field Comments and Branch Comments? 
 

• Field Comments are for internal ship use only and should not be a part of the final 
delivery package to the branch. 

 
• Branch Comments are to be filled in by the appropriate branch personnel only – these 

comments will be retained in the archived XML file and output as ‘red notes’ in the 
printed RTF/PDF document. 

 
How do I open completed documents (PI, DR, HVCR, DAPR)? 
 
To open completed XML files in the XML DR application, navigate to Load in the document 
sub-menu: 
 

File > Descriptive Report > Load 
 
You will then be prompted to browse to your XML file. 
 
How do I install Java Runtime Environment (JRE) on my machine, since this is required to use 
the PrintDR GUI? 
 
If you have Internet access on the machine, you can click on the following link to test whether 
you're running JRE: 
 

http://java.com/en/download/help/testvm.xml 
 
Otherwise, if you don't have Internet, you can search for the Java directory under C:\Program 
Files. 
 
If you aren't running JRE you will need to download it.  You can do so via this link: 
 

http://java.com/java/download/index.jsp?cid=jdp121116 
 
What if the PrintDR GUI still won’t work? 
 
If the PrintDR GUI still won’t work, open the command shell window that runs with the XML 
DR software.  If you see an error message that indicates the .fo file cannot be found, then the 
PrintDR GUI is not able to find one or more required files (XML, XSLT, XSD) to run the 
engines that print to PDF.  This often occurs when Pydro isn’t installed to the default directory. 
In order for the PrintDR GUI to function, Pydro must be installed to the following location: 
 

C:/Program Files/Pydro 
 
 
 
 

http://java.com/en/download/help/testvm.xml
http://java.com/java/download/index.jsp?cid=jdp121116
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Where can I look for upcoming functionality? 
 
A list of XML DR issues, along with their priority and status can be found on Port of Call.  The 
list is located by navigating to: 
 

OCS Port of Call > HSD > XML DR > XML DR Issues 
 
You can also add issues to this list.  Please be sure to add a detailed description of the 
functionality you would like to see in the GUI, so the XML team will be able to better 
understand and meet your needs.  Please note that not all requests will be applied, but each 
request will certainly be given serious consideration. 

https://poc.nos.noaa.gov/hsd/xml_dr/Lists/XML%20DR%20Issues/Unresolved%20XML%20DR%20Issues.aspx
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